Son Yazılar
Anasayfa > Genel > Cisco Router on a Stick

Cisco Router on a Stick

 

Bu makalemi Cisco Vlan Oluşturulması ve Port Atamaları makelesinin devamı olarak düşünebiliriz.

Öncelikle 3 katlı bir şirket düşünelim ve şirketimizde 3 adet Departman mevcut bunlar :

  • İnsan Kaynakları
  • Muhasebe
  • IT

Yapımızda her bir departman için ayrı vlan oluşturuyoruz.

RESİMLERİ rahat görebilmek için üzerine tıklayınız…

 

 

 

 

 

Projeye bakarak elimizde neler var öncelikle onlara bir bakalım ;

  • Departmanların Vlan numaraları ve isimleri
  • Departmanlara ayrılan Network ID ler ve Default Gatewayleri
  • Vtp Domain yapısı için gerekli olan Trunk port aralıkları
  • Vlan yapımızın çalışır duruma getirmek için gerekli 7 aşama…

Şimdi 1. maddeden başlıcak olursak öncelikle Vtp Domain  yapımızın birbiriyle haberleşmesini sağlmak için Switchler üzerinde Trunk portları atayalım…. 

Bunun için komutlarımız.   Bütün Switchler de tek tek…..

Switch>enable
Switch#configure terminal
Switch(config)#interface range fastEthernet 0/23-24
Switch(config-if-range)#switchport mode trunk

Evet gelelim 2. maddeye

Routerımızın bağlı olduğu portun çalışmasını sağlamak için gireceğimiz komut….

Router>en
Router#conf t
Router(config)#interface fastEthernet 0/0
Router(config-if)#no sh

3. Madde de Vtp domain kurulumu ve diğer Switchlerin domaine join edilmesi işlemini gerçekleştirelim.

Vtp domain ismimiz SAMET  ve parolamız 123 olsun…

Not: Vtp Domain herhangi bir switch üzerinde kurulabilir.Diğer Switchler üzerinde sadece Password işlemi gerçekleştirilir.

Switch#en
Switch#conf t
Switch(config)#vtp domain SAMET
Changing VTP domain name from NULL to SAMET
Switch(config)#vtp password 123
Setting device VLAN database password to 123

Diğer 2 Switchde ise ;
Switch#en
Switch#conf t
Switch(config)#vtp password 123
Setting device VLAN database password to 123

 4. Madde

Vtp Domain yapımız çalışır duruma geldikten sonra Departmanlara ait Vlanları herhangi bir Switch üzerinde oluşturuyoruz.

Vtp domain yapımız sayesinde tek bir switch üzerinden oluşturduğumuz vlanlarımızı bütün switchlerde görüyoruz…

Bu işlem için komutlarımız ….

Switch#en
Switch#conf t
Switch(config)#vlan 10
Switch(config-vlan)#name IK
Switch(config-vlan)#vlan 20
Switch(config-vlan)#name Muhasebe
Switch(config-vlan)#vlan 30
Switch(config-vlan)#name IT

Şuana kadar yaptıklarımızı görecek olursak…

 

 

 

 

 

 

5.Madde

Port atamaları işlemini Departmanlara ait Vlan numaraları ve Port aralıklarına bakarak bütün switchlerimiz üzerinde tek tek gerçekleştiriyoruz…

Switch#en
Switch#conf t
Switch(config)#interface range fastEthernet 0/1-5
Switch(config-if-range)#switchport access vlan 10
exit
Switch(config)#interface range fastEthernet 0/6-10
Switch(config-if-range)#switchport access vlan 20
exit
Switch(config)#interface range fastEthernet 0/11-20
Switch(config-if-range)#switchport access vlan 30 

6.Madde

Router on a Stick işlemini tek bir kablo üzerinden Vlan adeti kadar Sanal kablo geçtiğini düşünebiliriz.

Yani 3 adet Departmanımız ve Vlanımız olduğuna göre Router ve Switch arasındaki düz kablomuzun içinden 3 adet sanal kabloya ihtiyacımız olucak ….

Bu işlem için Router üzerinde ;

Router>en
Router#conf t
Router(config)#interface fastEthernet 0/0.10
Router(config-subif)#encapsulation dot1Q 10                                                                        
Router(config-subif)#ip address 192.168.1.254 255.255.255.0                                   
exit                                                                                                                                                            
Router(config)#interface fastEthernet 0/0.20
Router(config-subif)#encapsulation dot1Q 20
Router(config-subif)#ip address 192.168.2.254 255.255.255.0
exit
Router(config)#interface fastEthernet 0/0.30
Router(config-subif)#encapsulation dot1Q 30 
Router(config-subif)#ip address 192.168.3.254 255.255.255.0              

Yukarıda ( Router(config)#interface fastEthernet 0/0.10 )  Komutunu bahsettiğimiz Sanal kablo olarak düşünebiliriz.10 numarasını vermemdeki amaç vlan 10 na ait  olduğunu unutmamak için.Oraya 1 2 3   5   50  60 gibi   alakasız bir rakamda girebilirdik.

Router(config-subif)#encapsulation dot1Q 30  Burada verilen numaralar ise vlan numaralarımız bunları  kafamıza göre veremeyiz.

7.Madde

Son olarak Routerımız üzerinde Departmanlarımızda bulunan PC ler için DHCP Pool oluşturucaz .

Her bir departman için farklı Network ID belirlediğimiz için 3 adet DHCP Pool oluşturalım.

Router>en
Router#conf t
Router(config)#ip dhcp pool 10
Router(dhcp-config)#network 192.168.1.0 255.255.255.0                
Router(dhcp-config)#default-router 192.168.1.254
exit
Router(config)#ip dhcp pool 20
Router(dhcp-config)#network 192.168.2.0 255.255.255.0
Router(dhcp-config)#default-router 192.168.2.254
exit
Router(config)#ip dhcp pool 30
Router(dhcp-config)#network 192.168.3.0 255.255.255.0
Router(dhcp-config)#default-router 192.168.3.254

Yukarıda ( Router(config)#ip dhcp pool 10   ) Buraya girdiğimiz 10 da vlan 10 a ait olduğunu unutmamak için  girdiğimiz bir değer bu değerde farklılık gösterebilirdi.

 

 

 

 

 

Bütün işlemleri gerçekleştirdikten sonra Farklı Departmanlardaki Pclerin doğru ipleri alıp almadığını kontrol ediyoruz..

İnsan Kaynakları Departmanı PC1

 

 

 

 

 

Muhasebe Departmanı PC1

 

 

 

 

 

IT Departmanı PC1

Hakkında Samet ÖZGEN

Samet ÖZGEN
1993 Antalya doğumludur.İlk ve orta eğitimini Antalya da tamamladıktan sonra Plato Meslek Yüksekokulu-BilgeAdam işbirliğiyle yürütülen (İnternet ve Ağ Teknolojileri) programını tamamlamış bulunmaktadır.

Ayrıca

ApacheBench ile HTTP Server Benchmark Testi

Apache Server’ın içinde gelen bu tool ile herhangi bir web sitenin HTTP Benchmark istatiğini çıkarabiliyoruz. Buna ...

KoçSistem’den Maximus Bulut Akademi ile vNext Server 2016 Etkinlik Notlarımız

Dün MaestroPanel olarak KoçSistem‘in hazırladığı Maximus Bulut Akademisi etkinliğine katıldık. Sektörün önde gelenlerinden Mesut ALADAĞ‘ın ve ...

Bir Cevap Yazın